rrdtoolのアップデート

今年の1月末ぐらいから、yumのcronでエラーがあったとメールが届くようになった。

忙しくてしばらく放置していたがやっと対処できる時間ができたので調べてみた。

エラーの内容は、どうやらyumでperl-rrdtoolをアップデートしようとしたら依存関係でrrdtoolが必要だ。

みたいな感じらしい。

バージョンはperl-rrdtool-1.4.5-1にしようとしてrrdtool-1.4.5が必要らしいのでrpmパッケージを探してダウンロードした。

perl-rrdtool-1.4.5-1.el5.rf.i386.rpm

rrdtool-1.4.5-1.el5.wrl.i386.rpm

 

次に、1つずつアップデートしてみると、

# rpm -Fvh rrdtool-1.4.5-1.el5.wrl.i386.rpm
エラー: 依存性の欠如:
rrdtool = 1.4.4 は (インストール済み)perl-rrdtool-1.4.4-1.el5.rf.i386 に必要とされています

とやっぱり怒られてしまうので、2つまとめてアップデートすることにした。

その前に取りあえずテストしてみた。

# rpm -Fvh –test rrdtool-1.4.5-1.el5.wrl.i386.rpm perl-rrdtool-1.4.5-1.el5.rf.i386.rpm
準備中… ########################################### [100%]

うまくいきそうなので、–testを外して実行

# rpm -Fvh rrdtool-1.4.5-1.el5.wrl.i386.rpm perl-rrdtool-1.4.5-1.el5.rf.i386.rpm
準備中… ########################################### [100%]
1:rrdtool ########################################### [ 50%]
2:perl-rrdtool ########################################### [100%]

うまくいったようだ。

後は様子見…。

LINEで送る
Pocket

コメントは受け付けていません。